VMware ESXi S.M.A.R.T. auslesen

Dienstag, 2. Juni 2020 12:20

Das geht auf der Kommandozeile per SSH. Eine Liste der vorhandenen Geräte kann man sich mit folgendem Befehl anzeigen lassen:

# esxcli storage core device list

Die eigentlichen S.M.A.R.T.-Werte erhält man mit folgendem Befehl, wobei man für device den „naa-Namen“ des Gerätes auch aus dem vSphere-Web-Client verwenden kann:

# esxcli storage core device smart get -d device

 

Thema: VMware | Kommentare (0)

Uhrzeit auf einem Domänencontroller per NTP holen

Dienstag, 5. Mai 2020 22:47

Hier die Befehle, um auf einem Domänencontroller die Zeit von einem NTP-Server aktualisieren zu lassen, damit die Zeit in der gesamten Domäne richtig ist.

C:\Users\Administrator>w32tm /query /source
Free-running System Clock

C:\Users\Administrator>w32tm /config /syncfromflags:manual /update /reliable:yes /manualpeerlist:"de.pool.ntp.org"
Der Befehl wurde erfolgreich ausgeführt.

C:\Users\Administrator>w32tm /query /source
Free-running System Clock

C:\Users\Administrator>w32tm /query /source
de.pool.ntp.org

Weitergehende Infos gibt es hier.

Thema: Windows | Kommentare (0)

Windows 10 schließt Netzlaufwerkfenster ab und zu von alleine bei per GPO ausgerollten Netzlaufwerken

Dienstag, 5. Mai 2020 22:43

Einer unserer Kunden hatte über Wochen das Problem, dass sich bei seinen Mitarbeitern auf einmal alle zum zentralen Netzlaufwerk geöffneten Explorer-Fenster schlossen. Schlimmer noch: Einige Programme stürzten einfach ab, wenn sich die Fenster schlossen. In den Ereignislogs war weder auf dem Server noch auf den Rechnern etwas zu finden und es trat auch nicht bei allen Rechnern gleichzeitig auf. Nach langem Rumsuchen und Ausprobieren bin ich über diesen Beitrag hier gestolpert: File Explorer Mapped Drives Close Spontaneously

Thema: Windows | Kommentare (0)

Windows Domäne FSMO-Rollen per Powershell übertragen

Donnerstag, 23. Januar 2020 9:28

Das ist ein einfacher Einzeiler. Die FSMO-Rollen müssen immer zwingend an einen anderen Domänencontroller übertragen werden, wenn der Domänencontroller, der die Rollen aktuell innehat, herabgestuft werden soll.

Move-ADDirectoryServerOperationMasterRole -Identity  -OperationMasterRole SchemaMaster,RIDMaster,InfrastructureMaster,DomainNamingMaster,PDCEmulator

Thema: Windows | Kommentare (0)

Partition online resizen auf alten Windows 2003 Servern

Mittwoch, 11. September 2019 22:27

C:\Dokumente und Einstellungen\Administrator>diskpart

Microsoft DiskPart Version 5.2.3790.3959
Copyright (C) 1999-2001 Microsoft Corporation.
Auf Computer: SERVER1

DISKPART> list disk

Datentr. Status Größe Frei Dyn GPT
-------- ---------- ------- ------- --- ---
0 Online 60 GB 0 B
1 Online 200 GB 0 B
2 Online 200 GB 80 GB

DISKPART> select disk 2

Datenträger 2 ist jetzt der gewählte Datenträger.

DISKPART> list partition

Partition Typ Größe Offset
------------- ---------------- ------- -------
Partition 1 Primär 120 GB 32 KB

DISKPART> select partition 1

Partition 1 ist jetzt die gewählte Partition.

DISKPART> extend

Das Volume wurde erfolgreich erweitert.

DISKPART> exit
Datenträgerpartitionierung wird beendet...

Thema: Windows | Kommentare (0)

Ceph Legacy BlueStore stats reporting detected on X OSD(s)

Dienstag, 10. September 2019 11:54

Nach einem Update auf Ceph Nautilus hatte ich im ceph status auf einmal die Meldung Legacy BlueStore stats reporting detected on X OSD(s). Anscheinend hat ceph nach dem Update nicht automatisch die entsprechenden OSDs aktualisiert. Abhilfe schafft hier das Tool ceph-bluestore-tool. Wichtig hierbei ist natürlich, dass man das immer nur für eine OSD zur Zeit macht, da man während der Ausführung die jeweilige OSD offline nehmen muss. Den folgenden Befehl führ man für jede betroffene OSD auf jedem Host aus:

Thema: Linux | Kommentare (0)

Outlook fragt nach Microsoft-Konto, obwohl nur lokales Exchange-Konto verwendet wird

Mittwoch, 24. Juli 2019 15:23

Ich hatte auf meinem Laptop seit einiger Zeit das merkwürdige Phänomen, dass Outlook manchmal nach längerer Benutzung auf einmal in einem merkwürdigen Fenster nach meinen Zugangsdaten gefragt hat. Es stellte sich recht schnell heraus, dass dort nicht die Zugangsdaten zu meinem Mailkonto (eigener Exchange) sondern Zugangsdaten zu einem Microsoft-Konto abgefragt wurden. Merkwürdigerweise war das Outlook aber auch keine Office365-Installation. Wo kommt also der Dialog auf einmal her?

Thema: Windows | Kommentare (0)

Mikrotik IPv6 Default Firewall Rules

Dienstag, 9. Juli 2019 18:18

Hier ein einfacher Vorschlag für IPv6-Firewall-Regeln für Mikrotik Router, die als CPE eingesetzt werden.

/ipv6 firewall filter
add chain=input protocol=icmpv6
add chain=input connection-state=established,related
add chain=input dst-port=546 in-interface=wan protocol=udp src-port=547
add action=drop chain=input connection-state=invalid
add action=drop chain=input connection-state=new in-interface=ether1-wan
add chain=forward protocol=icmpv6
add chain=forward connection-state=established,related
add chain=forward connection-state=new in-interface=!wan
add action=drop chain=forward connection-state=invalid
add action=drop chain=forward connection-state=new in-interface=wan

Thema: Mikrotik | Kommentare (1)

Fundstück: Sozialismus vs. Kapitalismus

Sonntag, 9. Juni 2019 16:25

Ich bin ja ein entschiedener Gegner sozialistischer Ideen und da habe ich letztens im Heise-Forum (!) im Rahmen einer Diskussion um die Versteigerung der Mobilfunklizenzen folgenden, wunderbaren Betrag gefunden, der sehr anschaulich darstellt, warum Kapitalismus/Marktwirtschaft im Gegensatz zu Kommunismus/Sozialismus einfach besser funktioniert und trotz aller Nachteile den Einzelnen besser teilhaben lässt.

Der Beitrag ist im Original von /mecki78 und der Thread dazu lässt sich abrufen unter diesem Link.

Thema: Politik | Kommentare (0)

Windows Dateien inklusive ACLs per robocopy kopieren

Samstag, 1. Juni 2019 22:22

Der folgende Befehl kopiert alle Dateien und Unterordner in src nach dst und kopiert dabei sowohl die Informationen zum Erstelldatum, letzter Zugriff als auch die NTFS-Berechtigungen mit. Damit kann man also eine Art Backup erstellen oder aus einem Backup Daten zurückkopieren.

robocopy src dst /MIR /COPYALL

Ich verwende diesen Befehl zum Beispiel, wenn ich aus einem Acronis-Backup nur einige Ordner wiederherstellen möchte, aber die ACLs erhalten bleiben sollen. Dann stelle ich gerne das komplette Laufwerk in Kopie her, binde es ein und kopiere denn selektiv den Ordner, der wiederhergestellt werden soll.

Thema: Windows | Kommentare (0)